[12:49] Post by HG @ Stadia
[20:00] Lottoziehung in 05d 00:00h
[20:32] Post by steelworks @ Stadia
[21:01] Post by Athalion @ Stadia
[00:00] Songs gespielt gestern: 0
[00:10] Post by Aragorn @ Was sind Eure Lieblingsserien?
Trackmania Minecraft Andere Spiele

Windows XP zeigt keine Netzwerkverbindungen an

20.03.11, 19:03:31
Zahl
Normalerweise behebe ich PC Probleme von Bekannten nicht, wenn die mit Windows (und am besten noch mit Viren oder so nem Müll) zu tun haben, weil mir das einfach viel zu frickelig und um nervig ist. Notfalls zeige ich demonstrativ mein Linux Laptop, um zu unterstreichen, dass ich absolut keine Ahnung von Windows habe.
Aber was macht man nicht so alles für seine geliebten Familienmitglieder. So hat es da mal wieder jemand geschafft gehabt, nach nur 3 Tagen auf einem alten XP Laptop (allerdings frisch installiert und gepatcht) irgend einen Virus oder Spyware auf die Platte zu hauen. Scheinbar über ein komisches Downloadportal wie Softonic, die teilweise mit suspekten Installern für normale Freeware dem unbedarften User noch weiteren Schmarn unterjubeln wollen.
Nun gut, die Installation war schnell rückgängig gemacht, allerdings war das System schon irgendwie vermurkst. Hauptsächlich fiel auf, dass das Fenster mit den Netzwerkverbindungen (Eigenschaften von Netzwerkumgebung) leer war. Allerdings funktionierte die LAN Verbindung noch einwandfrei, also sah ich keinen Anlass, dem auf den Grund zu gehen -- Bis heute; denn nun sollte dank neuem WLAN-Router eben auf WLAN umgestellt werden. Allerdings fehlte auch im Systray das Icon des Adapters, und so war es unmöglich, ein Funknetzwerk zum Verbinden auszuwählen. Auch mit der Realtek Software zum WLAN Adapter ließ sich nichts machen, da der weitere komische Fehlermeldungen ausspuckte.
Also blieb nichts anderes Übrig, als nun doch diesem Problem auf den Grund zu gehen. Wenn man mal 10 Sekunden zum Googlen investiert sieht man schnell, dass das Problem allgemein bekannt ist, und man stolpert auch schnell immer wieder über zwei Lösungen.

Die eine ist eine Reihe von Befehlen, die man in der Konsole ausführen muss:
Code:
net stop netman
regsvr32 netman.dll 
regsvr32 netcfgx.dll 
regsvr32 netshell.dll 
regsvr32 atl.dll
regsvr32 hnetcfg.dll
net start netman

Die andere kümmert sich um die Einstellungen einiger Dienste:
1. Unter Start -> Ausführen services.msc eingeben.
2. Den Starttyp des Dienstes Plug & Play auf automatisch stellen (und starten).
3. Für den Dienst Remoteprozeduraufruf (RPC) genau das gleiche durchführen.
4. Den Netzwerkverbindungsdienst ebenfalls auf automatisch stellen, außerdem auf dem Register Anmelden den Haken bei Datenaustausch zwischen Dienst und Desktop zulassen setzen.

Beides löste das Problem hier nicht, und nach einiger Zeit fand ich noch einen kb Artikel direkt bei Microsoft, in dem sich für mich des Rätsels Lösung fand:
Der Benutzer SYSTEM muss auf den Ordner C:\WINDOWS\system32\wbem\Repository Vollzugriff haben, was auf dem Laptop hier nicht der Fall war. Außerdem wird dort noch darauf hingewiesen, dass man den Inhalt dieses Ordners auch mal komplett löschen kann, da der dann neu erstellt wird. Das hab ich zur Sicherheit auch gleich gemacht. Dazu muss erst temporär der Dienst Windows-Verwaltungsinstrumentation beendet werden. Nach einem Neustart ließ sich dann endlich das WLAN konfigurieren und nutzen.
Das ganze hat mich ne gute Stunde gekostet aber war immer noch schneller, als ne Neuinstallation....
 

Lesezeichen

Stichworte
netzwerk, windows xp
Kommentare (0)

Kommentar:
Benutzername: 
Email (nicht ausfüllen!): Sicherheitsgrafik


Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)
 
Aktivität
Chat (20 Min)
1 Zeile

Teamspeak 3

Alle Zeitangaben in WEZ +1. Es ist jetzt 08:41:17 Uhr.


Powered by vBulletin® Version 3.8.2 (Deutsch)
Copyright ©2000 - 2023, Jelsoft Enterprises Ltd.
Template-Modifikationen durch TMS
Die Betreiber haften nicht für die Inhalte der User. Die Beiträge spiegeln ausschließlich persönliche Meinungen wider, und nicht die der Seitenbetreiber.